aboutsummaryrefslogtreecommitdiffstats
path: root/hosts/arrakis/hardware-configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--hosts/arrakis/hardware-configuration.nix88
1 files changed, 59 insertions, 29 deletions
diff --git a/hosts/arrakis/hardware-configuration.nix b/hosts/arrakis/hardware-configuration.nix
index 4e67e65..8a439ab 100644
--- a/hosts/arrakis/hardware-configuration.nix
+++ b/hosts/arrakis/hardware-configuration.nix
@@ -16,42 +16,72 @@
zfs.extraPools = [ "data" ];
};
- fileSystems."/" =
- { device = "rpool/local/root";
- fsType = "zfs";
- };
+ fileSystems."/" = {
+ device = "rpool/local/root";
+ fsType = "zfs";
+ };
- fileSystems."/efiboot/efi1" =
- { device = "/dev/disk/by-label/ESP1";
- fsType = "vfat";
- options = [ "X-mount.mkdir" "iocharset=iso8859-1" ];
- };
+ fileSystems."/efiboot/efi1" = {
+ device = "/dev/disk/by-label/ESP1";
+ fsType = "vfat";
+ options = [ "X-mount.mkdir" "iocharset=iso8859-1" ];
+ };
- fileSystems."/efiboot/efi2" =
- { device = "/dev/disk/by-label/ESP2";
- fsType = "vfat";
- options = [ "X-mount.mkdir" "iocharset=iso8859-1" ];
- };
+ fileSystems."/efiboot/efi2" = {
+ device = "/dev/disk/by-label/ESP2";
+ fsType = "vfat";
+ options = [ "X-mount.mkdir" "iocharset=iso8859-1" ];
+ };
- fileSystems."/nix" =
- { device = "rpool/local/nix";
- fsType = "zfs";
- };
+ fileSystems."/nix" = {
+ device = "rpool/local/nix";
+ fsType = "zfs";
+ };
- fileSystems."/root" =
- { device = "rpool/user/home/root";
- fsType = "zfs";
- };
+ fileSystems."/root" = {
+ device = "rpool/user/home/root";
+ fsType = "zfs";
+ };
- fileSystems."/home/nipsy" =
- { device = "rpool/user/home/nipsy";
- fsType = "zfs";
- };
+ fileSystems."/home/nipsy" = {
+ device = "rpool/user/home/nipsy";
+ fsType = "zfs";
+ };
+
+ fileSystems."/srv/nfs/keepers" = {
+ device = "/data/home/nipsy/downloads/keepers";
+ options = [
+ "bind"
+ "defaults"
+ "nofail"
+ "x-systemd.requires=zfs-mount.service"
+ ];
+ };
- swapDevices =
- [ { device = "/dev/disk/by-label/swap1"; }
- { device = "/dev/disk/by-label/swap2"; }
+ fileSystems."/srv/nfs/movies" = {
+ device = "/data/home/nipsy/downloads/movies";
+ options = [
+ "bind"
+ "defaults"
+ "nofail"
+ "x-systemd.requires=zfs-mount.service"
];
+ };
+
+ fileSystems."/srv/nfs/tv" = {
+ device = "/data/home/nipsy/downloads/tv";
+ options = [
+ "bind"
+ "defaults"
+ "nofail"
+ "x-systemd.requires=zfs-mount.service"
+ ];
+ };
+
+ swapDevices = [
+ { device = "/dev/disk/by-label/swap1"; }
+ { device = "/dev/disk/by-label/swap2"; }
+ ];
hardware = {
bluetooth.enable = true;