aboutsummaryrefslogtreecommitdiffstats
path: root/ginaz/home.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--home/nipsy/common/core/zsh/zshrc (renamed from ginaz/home.nix)124
1 files changed, 2 insertions, 122 deletions
diff --git a/ginaz/home.nix b/home/nipsy/common/core/zsh/zshrc
index c2f84f7..9e43d1d 100644
--- a/ginaz/home.nix
+++ b/home/nipsy/common/core/zsh/zshrc
@@ -1,120 +1,3 @@
-{ config, pkgs, ... }:
-
-{
- gtk = {
- enable = true;
- gtk3.extraConfig.gtk-application-prefer-dark-theme = true;
- gtk4.extraConfig.gtk-application-prefer-dark-theme = true;
- };
-
- home.username = "nipsy";
- home.homeDirectory = "/home/nipsy";
- home.stateVersion = "23.11";
-
- programs.git = {
- enable = true;
- userName = "Mark Nipper";
- userEmail = "nipsy@bitgnome.net";
- extraConfig.pull.rebase = true;
- };
-
- programs.home-manager.enable = true;
-
- programs.tmux = {
- enable = true;
- extraConfig = ''
- #set-option -ga terminal-overrides ",st-256color:Tc"
- set -as terminal-features ",foot*:RGB"
- set -as terminal-features ",st-256color:RGB"
- set -ga monitor-bell on
- set -g history-limit 100000
- set -g bell-action any
- #set -g bell-on-alert on
-
- set -s escape-time 0
-
- setw -g aggressive-resize on
- setw -g wrap-search off
-
- bind-key a send-prefix
- bind-key k kill-session
- bind-key H pipe-pane -o 'cat >> ~/.tmux.log.#h-#S-#I-#P'
-
- #bind-key m \
- # set -g mouse on \;\
- # display 'Mouse: ON'
- #bind M \
- # set -g mouse off \;\
- # display 'Mouse: OFF'
-
- # vim-like copypaste mode
- set-window-option -g mode-keys vi
- bind-key -T copy-mode-vi v send -X begin-selection
- bind-key -T copy-mode-vi y send -X copy-pipe "xclip -selection clipboard"
- bind-key -T copy-mode-vi C-v send -X rectangle-toggle
- bind-key P run "tmux set-buffer \"$(xclip -o -selection clipboard)\"; tmux paste-buffer"
-
- # don't exit copy mode after selection
- #set -s mouse on
- #bind-key -T copy-mode-vi MouseDragEnd1Pane send-keys -X copy-selection -x
- '';
- };
-
- programs.vim = {
- enable = true;
- extraConfig = ''
- " Handling of big files - William Natter, Tony Mechelynck and others
- " fairly certain that BufSizeThreshold is in bytes
- let g:SaveUndoLevels = &undolevels
- let g:BufSizeThreshold = 5242880
- if has("autocmd")
- au VimEnter * let g:SaveUndoLevels = &undolevels
- au BufReadPre * if getfsize(expand("%")) >= g:BufSizeThreshold | setlocal noswapfile | endif
- au BufEnter * if getfsize(expand("%")) < g:BufSizeThreshold | let &undolevels=g:SaveUndoLevels | else | setlocal undolevels=-1 | endif
- au BufEnter * if getfsize(expand("%")) < g:BufSizeThreshold | syntax on | else | syntax off | endif
- endif
-
- set mouse&
- set noautoindent " always set autoindenting off
-
- " enable better 24-bit color support
- "let &t_8f = "\<Esc>[38;2;%lu;%lu;%lum"
- "let &t_8b = "\<Esc>[48;2;%lu;%lu;%lum"
- set termguicolors
-
- " If using a dark background within the editing area and syntax highlighting
- " turn on this option as well
- set background=dark
-
- if has("autocmd")
- " Enabled file type detection
- " Use the default filetype settings. If you also want to load indent files
- " to automatically do language-dependent indenting add 'indent' as well.
- filetype plugin on
- "filetype indent on
- endif " has ("autocmd")
-
- " The following are commented out as they cause vim to behave a lot
- " different from regular vi. They are highly recommended though.
- set showcmd " Show (partial) command in status line.
- set showmatch " Show matching brackets.
- set ignorecase " Do case insensitive matching
- set incsearch " Incremental search
- "set expandtab " replace tabs with spaces
- set smarttab " use shiftwidth instead of tabstop at start of line
- set spell spelllang=en_us " turn on the spell check
-
- set laststatus=2
- set statusline=%<%f%h%m%r%=%{&ff}\ %Y\ %b\ 0x%B\ \ %l,%c%V\ %P
-
- map <F5> :w<CR><bar>:!clear;go run %<CR>
- map <F6> :w<CR><bar>:%! gofmt<CR>
- '';
- };
-
- programs.zsh = {
- enable = true;
- initExtra = ''
umask 022
#export GOROOT="''${HOME}/.local/go"
@@ -192,8 +75,8 @@ setopt LONG_LIST_JOBS NO_HUP
setopt NO_BEEP
lsopt='--color=auto'
-alias ll="ls -alFh $lsopt"
-alias la="ls -aF $lsopt"
+#alias ll="ls -alFh $lsopt"
+#alias la="ls -aF $lsopt"
alias cal="ncal -b"
#alias grep='grep --color=always' # cannot do this as it breaks shell pipelines
alias talk='gnutalk --curses'
@@ -285,6 +168,3 @@ function precmd {
}
PS1='%# '
- '';
- };
-}