aboutsummaryrefslogtreecommitdiffstats
path: root/ginaz/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'ginaz/configuration.nix')
-rw-r--r--ginaz/configuration.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/ginaz/configuration.nix b/ginaz/configuration.nix
index ac85c26..8b19828 100644
--- a/ginaz/configuration.nix
+++ b/ginaz/configuration.nix
@@ -26,11 +26,14 @@
# List packages installed in system profile. To search, run:
# $ nix search wget
environment.systemPackages = with pkgs; [
+ bespokesynth
curl
dmenu
feh
geeqie
git
+ google-authenticator
+ google-chrome
i3
i3status
netcat-openbsd
@@ -44,9 +47,13 @@
stoken
vim
wget
+ winetricks
+ wineWowPackages.stagingFull
xdotool
xorg.xdpyinfo
xscreensaver
+ yabridge
+ yabridgectl
];
i18n.defaultLocale = "en_US.UTF-8";
@@ -71,6 +78,20 @@
programs.tmux.enable = true;
programs.zsh.enable = true;
+ security.pam.services = {
+ chfn.googleAuthenticator.enable = true;
+ chsh.googleAuthenticator.enable = true;
+ cups.googleAuthenticator.enable = true;
+ lightdm.googleAuthenticator.enable = true;
+ login.googleAuthenticator.enable = true;
+ other.googleAuthenticator.enable = true;
+ sshd.googleAuthenticator.enable = true;
+ su.googleAuthenticator.enable = true;
+ sudo.googleAuthenticator.enable = true;
+ vlock.googleAuthenticator.enable = true;
+ xlock.googleAuthenticator.enable = true;
+ xscreensaver.googleAuthenticator.enable = true;
+ };
security.polkit = {
enable = true;
extraConfig = ''