aboutsummaryrefslogtreecommitdiffstats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix11
1 files changed, 8 insertions, 3 deletions
diff --git a/flake.nix b/flake.nix
index b9bee83..ef8e092 100644
--- a/flake.nix
+++ b/flake.nix
@@ -2,6 +2,7 @@
description = "nipsy's NixOS configuration";
inputs = {
+
disko = {
url = "github:nix-community/disko";
inputs.nixpkgs.follows = "nixpkgs-unstable";
@@ -26,13 +27,16 @@
url = "github:Mic92/sops-nix";
inputs.nixpkgs.follows = "nixpkgs-unstable";
};
+
};
outputs = inputs@{ home-manager-stable, home-manager-unstable, nixos-hardware, nixpkgs-stable, nixpkgs-unstable, sops-nix, ... }: rec {
+
nixosConfigurations = {
+
arrakis = nixpkgs-unstable.lib.nixosSystem {
pkgs = pkgs-unstable;
- #specialArgs = inputs;
+ #specialArgs = { inherit inputs; };
system = "x86_64-linux";
modules = [
./hosts/arrakis
@@ -47,7 +51,7 @@
darkstar = nixpkgs-unstable.lib.nixosSystem {
pkgs = pkgs-unstable;
- #specialArgs = inputs;
+ #specialArgs = { inherit inputs; };
system = "x86_64-linux";
modules = [
./hosts/darkstar
@@ -61,7 +65,7 @@
ginaz = nixpkgs-unstable.lib.nixosSystem {
pkgs = pkgs-unstable;
- #specialArgs = inputs;
+ #specialArgs = { inherit inputs; };
system = "x86_64-linux";
modules = [
./hosts/ginaz
@@ -112,4 +116,5 @@
overlays = [(import ./pkgs)];
};
};
+
}