aboutsummaryrefslogtreecommitdiffstats
path: root/hosts/uranus/default.nix
diff options
context:
space:
mode:
authorMark Nipper <nipsy@bitgnome.net>2024-11-11 19:05:02 -0800
committerMark Nipper <nipsy@bitgnome.net>2024-11-11 19:05:02 -0800
commitcb3885e72abaa985e0e1fd95f6e57382c7c343e7 (patch)
tree04fe914816b35de2a2e6a9d7eef2b1e296490492 /hosts/uranus/default.nix
parent2f0664317ee6b6dd9bd05844582346b0b6fec1b8 (diff)
downloadnix-cb3885e72abaa985e0e1fd95f6e57382c7c343e7.tar
nix-cb3885e72abaa985e0e1fd95f6e57382c7c343e7.tar.gz
nix-cb3885e72abaa985e0e1fd95f6e57382c7c343e7.tar.bz2
nix-cb3885e72abaa985e0e1fd95f6e57382c7c343e7.tar.lz
nix-cb3885e72abaa985e0e1fd95f6e57382c7c343e7.tar.xz
nix-cb3885e72abaa985e0e1fd95f6e57382c7c343e7.tar.zst
nix-cb3885e72abaa985e0e1fd95f6e57382c7c343e7.zip
Add @uranus
Diffstat (limited to '')
-rw-r--r--hosts/uranus/default.nix66
1 files changed, 66 insertions, 0 deletions
diff --git a/hosts/uranus/default.nix b/hosts/uranus/default.nix
new file mode 100644
index 0000000..2128dc2
--- /dev/null
+++ b/hosts/uranus/default.nix
@@ -0,0 +1,66 @@
+{ config, inputs, outputs, pkgs, ... }: {
+ boot = {
+ initrd.kernelModules = [ "amdgpu" "zfs" ];
+ #kernel.sysctl = {
+ # "net.ipv4.ip_forward" = true;
+ #};
+ loader = {
+ efi.canTouchEfiVariables = true;
+ systemd-boot.enable = true;
+ timeout = 3;
+ };
+ supportedFilesystems = [ "zfs" ];
+ zfs.devNodes = "/dev/disk/by-label";
+ };
+
+ environment.systemPackages = with pkgs; [
+ wpa_supplicant
+ ];
+
+ imports = [
+ ./hardware-configuration.nix
+ ../common/core
+ ../common/optional/misc.nix
+ ../common/optional/services/fwupd.nix
+ ../common/optional/services/openssh.nix
+ ../common/optional/zfs.nix
+ ../common/users/nipsy
+ ../common/users/root
+ ];
+
+ networking = {
+ hostId = "46fdaa8e";
+ hostName = "uranus";
+ domain = "bitgnome.net";
+ nftables.enable = true;
+ wireless = {
+ enable = true;
+ userControlled.enable = true;
+ };
+ };
+
+ nixpkgs = {
+ config.allowUnfree = true;
+ hostPlatform = "x86_64-linux";
+ overlays = [
+ outputs.overlays.additions
+ outputs.overlays.modifications
+ outputs.overlays.master-packages
+ outputs.overlays.stable-packages
+ ];
+ };
+
+ #sops = {
+ # age.sshKeyPaths = [ "/etc/ssh/ssh_host_ed25519_key" ];
+ # defaultSopsFile = ../secrets/uranus.yaml;
+
+ # secrets = {
+ # "kea-dhcp4_conf" = {};
+ # "nftables/forward" = {};
+ # "nftables/ssh" = {};
+ # "nix-access-token-github" = {};
+ # };
+ #};
+
+ system.stateVersion = "24.11";
+}