aboutsummaryrefslogtreecommitdiffstats
path: root/hosts/kaitain/hardware-configuration.nix
diff options
context:
space:
mode:
authorMark Nipper <nipsy@bitgnome.net>2024-06-21 13:18:11 -0700
committerMark Nipper <nipsy@bitgnome.net>2024-06-21 13:18:11 -0700
commit42951df89da73eb53959fde02014e8a63d56065e (patch)
tree46d4f06401eeba7662ecc7837f4827e86041aaeb /hosts/kaitain/hardware-configuration.nix
parent89867e408dec0c3a48bbbaec2173ee8d140f2adc (diff)
downloadnix-42951df89da73eb53959fde02014e8a63d56065e.tar
nix-42951df89da73eb53959fde02014e8a63d56065e.tar.gz
nix-42951df89da73eb53959fde02014e8a63d56065e.tar.bz2
nix-42951df89da73eb53959fde02014e8a63d56065e.tar.lz
nix-42951df89da73eb53959fde02014e8a63d56065e.tar.xz
nix-42951df89da73eb53959fde02014e8a63d56065e.tar.zst
nix-42951df89da73eb53959fde02014e8a63d56065e.zip
Add new Virtualbox VM kaitain
Diffstat (limited to '')
-rw-r--r--hosts/kaitain/hardware-configuration.nix44
1 files changed, 44 insertions, 0 deletions
diff --git a/hosts/kaitain/hardware-configuration.nix b/hosts/kaitain/hardware-configuration.nix
new file mode 100644
index 0000000..0ca1a06
--- /dev/null
+++ b/hosts/kaitain/hardware-configuration.nix
@@ -0,0 +1,44 @@
+# Do not modify this file! It was generated by ‘nixos-generate-config’
+# and may be overwritten by future invocations. Please make changes
+# to /etc/nixos/configuration.nix instead.
+{ config, lib, pkgs, modulesPath, ... }:
+
+{
+ imports =
+ [ #(modulesPath + "/installer/scan/not-detected.nix")
+ ];
+
+ boot.initrd.availableKernelModules = [ "ohci_pci" "ehci_pci" "ata_piix" "virtio_pci" "virtio_scsi" "sd_mod" "sr_mod" ];
+ boot.initrd.kernelModules = [ ];
+ boot.kernelModules = [ ];
+ boot.extraModulePackages = [ ];
+
+ fileSystems."/" =
+ { device = "rpool/local/root";
+ fsType = "zfs";
+ };
+
+ fileSystems."/boot" =
+ { device = "/dev/disk/by-label/boot";
+ fsType = "vfat";
+ };
+
+ fileSystems."/nix" =
+ { device = "rpool/local/nix";
+ fsType = "zfs";
+ };
+
+ fileSystems."/root" =
+ { device = "rpool/user/home/root";
+ fsType = "zfs";
+ };
+
+ fileSystems."/home/nipsy" =
+ { device = "rpool/user/home/nipsy";
+ fsType = "zfs";
+ };
+
+ swapDevices =
+ [ { device = "/dev/disk/by-label/swap"; }
+ ];
+}