aboutsummaryrefslogtreecommitdiffstats
path: root/ginaz/hardware-configuration.nix
diff options
context:
space:
mode:
authorMark Nipper <nipsy@bitgnome.net>2024-02-26 15:53:49 -0800
committerMark Nipper <nipsy@bitgnome.net>2024-02-26 15:53:49 -0800
commit931658a79bb5a76e9d1d64bf0f09b8629c9083b1 (patch)
tree7ed5eac400e11d81e08523f35c28fb2fbcbb0d72 /ginaz/hardware-configuration.nix
downloadnix-931658a79bb5a76e9d1d64bf0f09b8629c9083b1.tar
nix-931658a79bb5a76e9d1d64bf0f09b8629c9083b1.tar.gz
nix-931658a79bb5a76e9d1d64bf0f09b8629c9083b1.tar.bz2
nix-931658a79bb5a76e9d1d64bf0f09b8629c9083b1.tar.lz
nix-931658a79bb5a76e9d1d64bf0f09b8629c9083b1.tar.xz
nix-931658a79bb5a76e9d1d64bf0f09b8629c9083b1.tar.zst
nix-931658a79bb5a76e9d1d64bf0f09b8629c9083b1.zip
Add initial NixOS configuration for ginaz
Diffstat (limited to '')
-rw-r--r--ginaz/hardware-configuration.nix47
1 files changed, 47 insertions, 0 deletions
diff --git a/ginaz/hardware-configuration.nix b/ginaz/hardware-configuration.nix
new file mode 100644
index 0000000..3d76693
--- /dev/null
+++ b/ginaz/hardware-configuration.nix
@@ -0,0 +1,47 @@
+# Do not modify this file! It was generated by ‘nixos-generate-config’
+# and may be overwritten by future invocations. Please make changes
+# to /etc/nixos/configuration.nix instead.
+{ config, lib, pkgs, modulesPath, ... }:
+
+{
+ imports =
+ [ (modulesPath + "/installer/scan/not-detected.nix")
+ ];
+
+ boot.initrd.availableKernelModules = [ "nvme" "xhci_pci" "usb_storage" "sd_mod" ];
+ boot.initrd.kernelModules = [ ];
+ boot.kernelModules = [ "kvm-amd" ];
+ boot.extraModulePackages = [ ];
+
+ fileSystems."/" =
+ { device = "rpool/local/root";
+ fsType = "zfs";
+ };
+
+ fileSystems."/boot" =
+ { device = "/dev/disk/by-label/boot";
+ fsType = "vfat";
+ };
+
+ fileSystems."/nix" =
+ { device = "rpool/local/nix";
+ fsType = "zfs";
+ };
+
+ fileSystems."/root" =
+ { device = "rpool/user/home/root";
+ fsType = "zfs";
+ };
+
+ fileSystems."/home/nipsy" =
+ { device = "rpool/user/home/nipsy";
+ fsType = "zfs";
+ };
+
+ swapDevices =
+ [ { device = "/dev/disk/by-label/swap"; }
+ ];
+
+ nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
+ hardware.cpu.amd.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
+}