aboutsummaryrefslogtreecommitdiffstats
path: root/ginaz/configuration.nix
diff options
context:
space:
mode:
authorMark Nipper <nipsy@bitgnome.net>2024-02-29 01:32:46 -0800
committerMark Nipper <nipsy@bitgnome.net>2024-02-29 01:32:46 -0800
commit71fa49e4b0a577617fa4bbe8155e1f81e1aed02d (patch)
tree71f6a504a177070d9cfc4786df5c609ae1dc9a3f /ginaz/configuration.nix
parentb11251fba9ec0e5e0709b6f74153eb5aeba2430d (diff)
downloadnix-71fa49e4b0a577617fa4bbe8155e1f81e1aed02d.tar
nix-71fa49e4b0a577617fa4bbe8155e1f81e1aed02d.tar.gz
nix-71fa49e4b0a577617fa4bbe8155e1f81e1aed02d.tar.bz2
nix-71fa49e4b0a577617fa4bbe8155e1f81e1aed02d.tar.lz
nix-71fa49e4b0a577617fa4bbe8155e1f81e1aed02d.tar.xz
nix-71fa49e4b0a577617fa4bbe8155e1f81e1aed02d.tar.zst
nix-71fa49e4b0a577617fa4bbe8155e1f81e1aed02d.zip
Use UTC for hardware clock and open SSH port
Diffstat (limited to '')
-rw-r--r--ginaz/configuration.nix7
1 files changed, 3 insertions, 4 deletions
diff --git a/ginaz/configuration.nix b/ginaz/configuration.nix
index 99fdba2..e1d0d4c 100644
--- a/ginaz/configuration.nix
+++ b/ginaz/configuration.nix
@@ -2,16 +2,13 @@
# your system. Help is available in the configuration.nix(5) man page, on
# https://search.nixos.org/options and in the NixOS manual (`nixos-help`).
-{ config, lib, pkgs, ... }:
-
-{
+{ config, lib, pkgs, ... }: {
imports =
[ # Include the results of the hardware scan.
./hardware-configuration.nix
];
boot.initrd.kernelModules = [ "amdgpu" "zfs" ];
- #boot.initrd.postDeviceCommands = ''zpool import -lf rpool'';
boot.kernelPackages = config.boot.zfs.package.latestCompatibleLinuxPackages;
boot.loader.efi.canTouchEfiVariables = true;
boot.loader.generationsDir.copyKernels = true;
@@ -222,6 +219,7 @@
services.blueman.enable = true;
services.openssh = {
enable = true;
+ openFirewall = true;
settings.PasswordAuthentication = false;
settings.KbdInteractiveAuthentication = false;
settings.PermitRootLogin = "yes";
@@ -275,6 +273,7 @@
};
};
+ time.hardwareClockInLocalTime = true;
time.timeZone = "America/Los_Angeles";
users.groups.nipsy.gid = 1000;