aboutsummaryrefslogtreecommitdiffstats
path: root/flake.nix
diff options
context:
space:
mode:
authorMark Nipper <nipsy@bitgnome.net>2024-10-21 09:05:10 -0700
committerMark Nipper <nipsy@bitgnome.net>2024-10-21 09:05:10 -0700
commit8c27b854f93f3c3e13b63d4597bc5755f4c4eb2f (patch)
treef59fb4548b924cba23641e53d77feadfecef2d89 /flake.nix
parent7468811cb3fc17174e85d6b7dc68b657cb84675b (diff)
downloadnix-8c27b854f93f3c3e13b63d4597bc5755f4c4eb2f.tar
nix-8c27b854f93f3c3e13b63d4597bc5755f4c4eb2f.tar.gz
nix-8c27b854f93f3c3e13b63d4597bc5755f4c4eb2f.tar.bz2
nix-8c27b854f93f3c3e13b63d4597bc5755f4c4eb2f.tar.lz
nix-8c27b854f93f3c3e13b63d4597bc5755f4c4eb2f.tar.xz
nix-8c27b854f93f3c3e13b63d4597bc5755f4c4eb2f.tar.zst
nix-8c27b854f93f3c3e13b63d4597bc5755f4c4eb2f.zip
Remove nVidia patches
Diffstat (limited to '')
-rw-r--r--flake.nix9
1 files changed, 2 insertions, 7 deletions
diff --git a/flake.nix b/flake.nix
index fee0488..e263287 100644
--- a/flake.nix
+++ b/flake.nix
@@ -23,11 +23,6 @@
nixpkgs-stable.url = "github:nixos/nixpkgs/release-24.05";
nixpkgs-unstable.url = "github:nixos/nixpkgs/nixos-unstable";
- nvidia-patch = {
- url = "github:icewind1991/nvidia-patch-nixos";
- inputs.nixpkgs.follows = "nixpkgs-unstable";
- };
-
sops-nix = {
url = "github:Mic92/sops-nix";
inputs.nixpkgs.follows = "nixpkgs-unstable";
@@ -35,14 +30,14 @@
};
- outputs = inputs@{ home-manager-stable, home-manager-unstable, nixos-hardware, nixpkgs-stable, nixpkgs-unstable, nvidia-patch, sops-nix, ... }: {
+ outputs = inputs@{ home-manager-stable, home-manager-unstable, nixos-hardware, nixpkgs-stable, nixpkgs-unstable, sops-nix, ... }: {
nixosConfigurations = {
arrakis = nixpkgs-unstable.lib.nixosSystem rec {
system = "x86_64-linux";
- specialArgs = { inherit inputs nvidia-patch;
+ specialArgs = {
pkgs = import nixpkgs-unstable {
inherit system;
config.allowUnfree = true;